Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 29, 2025 - 21:00 CDT
Scheduled
We will be conducting scheduled maintenance on March 29, 2025, starting at 9:00 PM CST to 10:00 PM CST. During this time, the e-Learning Systems may be temporarily unavailable.
Posted Mar 28, 2025 - 23:47 CDT
This scheduled maintenance affected: FOLKS Consulting Client Systems (Managed e-Learning Systems).